Network

Network Attributes

These attributes may be used for any network related operation.

Attributes:

KeyStabilityValue TypeDescriptionExample Values
network.carrier.iccDevelopmentstringThe ISO 3166-1 alpha-2 2-character country code associated with the mobile carrier network.DE
network.carrier.mccDevelopmentstringThe mobile carrier country code.310
network.carrier.mncDevelopmentstringThe mobile carrier network code.001
network.carrier.nameDevelopmentstringThe name of the mobile carrier.sprint
network.connection.stateRelease CandidatestringThe state of network connection [1]close_wait (see more)
network.connection.subtypeDevelopmentstringThis describes more details regarding the connection.type. It may be the type of cell technology connection, but it could be used for describing details about a Wi-Fi connection.LTE (see more)
network.connection.typeDevelopmentstringThe internet connection type.wifi (see more)
network.interface.nameRelease CandidatestringThe network interface name.lo; eth0
network.io.directionRelease CandidatestringThe direction of traffic from the perspective of the observing host’s physical or virtual network interface. It should not be used to represent the logical direction of a stateful connection or network flow.transmit (see more)
network.local.addressStablestringLocal address of the network connection - IP address or UNIX domain socket name.10.1.2.80; /tmp/my.sock
network.local.as.numberDevelopmentintThe Autonomous System Number (ASN) associated with the local IP address. [2]64496; 15169
network.local.as.organizationDevelopmentstringThe name of the organization associated with the autonomous system of the local IP address. [3]Example Networks Inc.; Google LLC
network.local.mac.addressDevelopmentstringLocal Media Access Control (MAC) address of the network connection. [4]00-00-5E-00-53-23
network.local.portStableintLocal port number of the network connection.65123
network.local.prefixDevelopmentstringThe IP prefix associated with the local IP address, in CIDR notation. [5]192.0.2.0/24; 2001:db8::/32
network.peer.addressStablestringPeer address of the network connection - IP address or UNIX domain socket name.10.1.2.80; /tmp/my.sock
network.peer.as.numberDevelopmentintThe Autonomous System Number (ASN) associated with the peer IP address. [6]64496; 15169
network.peer.as.organizationDevelopmentstringThe name of the organization associated with the autonomous system of the peer IP address. [7]Example Networks Inc.; Google LLC
network.peer.mac.addressDevelopmentstringPeer Media Access Control (MAC) address of the network connection. [8]00-00-5E-00-53-23
network.peer.portStableintPeer port number of the network connection.65123
network.peer.prefixDevelopmentstringThe IP prefix associated with the peer IP address, in CIDR notation. [9]192.0.2.0/24; 2001:db8::/32
network.protocol.nameStablestringOSI application layer or non-OSI equivalent. [10]amqp; http; mqtt
network.protocol.versionStablestringThe actual version of the protocol used for network communication. [11]1.1; 2
network.transportStablestringOSI transport layer or inter-process communication method. [12]tcp; udp (see more)
network.typeStablestringOSI network layer or non-OSI equivalent. [13]ipv4; ipv6 (see more)

[1] network.connection.state: Connection states are defined as part of the rfc9293

[2] network.local.as.number: This attribute SHOULD only be set when the local address is an IP address and the ASN is available from routing, enrichment, or lookup data. The value SHOULD be represented as an integer without the AS prefix.

[3] network.local.as.organization: This attribute SHOULD only be set when network.local.as.number is set and the organization name is available. The value SHOULD be the organization name as provided by the lookup or enrichment source, not the AS name or short code.

[4] network.local.mac.address: MAC addresses MUST be represented in IEEE RA hexadecimal form: as hyphen-separated octets in uppercase hexadecimal form from most to least significant.

[5] network.local.prefix:

The value MUST be an IPv4 or IPv6 network prefix in CIDR notation, as defined in RFC 4632 for IPv4 and RFC 4291 for IPv6. IPv4 prefixes MUST use a dotted-decimal address followed by / and a decimal prefix length from 0 to 32. IPv6 prefixes MUST use the canonical address text representation defined in RFC 5952, followed by / and a decimal prefix length from 0 to 128. All host bits in the address MUST be set to zero. The value MUST NOT contain a domain name, UNIX domain socket name, or IPv6 zone identifier.

Instrumentation or Collector receivers that populate this attribute MUST convert native representations, such as an address and subnet mask or an address and prefix length, to equivalent CIDR notation before emitting it.

This attribute MAY be set whether or not network.local.address is set. If network.local.address is also set to an IP address, it MUST use the same IP version and be contained in this prefix.

[6] network.peer.as.number: This attribute SHOULD only be set when the peer address is an IP address and the ASN is available from routing, enrichment, or lookup data. The value SHOULD be represented as an integer without the AS prefix.

[7] network.peer.as.organization: This attribute SHOULD only be set when network.peer.as.number is set and the organization name is available. The value SHOULD be the organization name as provided by the lookup or enrichment source, not the AS name or short code.

[8] network.peer.mac.address: MAC addresses MUST be represented in IEEE RA hexadecimal form: as hyphen-separated octets in uppercase hexadecimal form from most to least significant.

[9] network.peer.prefix:

The value MUST be an IPv4 or IPv6 network prefix in CIDR notation, as defined in RFC 4632 for IPv4 and RFC 4291 for IPv6. IPv4 prefixes MUST use a dotted-decimal address followed by / and a decimal prefix length from 0 to 32. IPv6 prefixes MUST use the canonical address text representation defined in RFC 5952, followed by / and a decimal prefix length from 0 to 128. All host bits in the address MUST be set to zero. The value MUST NOT contain a domain name, UNIX domain socket name, or IPv6 zone identifier.

Instrumentation or Collector receivers that populate this attribute MUST convert native representations, such as an address and subnet mask or an address and prefix length, to equivalent CIDR notation before emitting it.

This attribute MAY be set whether or not network.peer.address is set. If network.peer.address is also set to an IP address, it MUST use the same IP version and be contained in this prefix.

[10] network.protocol.name: The value SHOULD be normalized to lowercase.

[11] network.protocol.version: If protocol version is subject to negotiation (for example using ALPN), this attribute SHOULD be set to the negotiated version. If the actual protocol version is not known, this attribute SHOULD NOT be set.

[12] network.transport: The value SHOULD be normalized to lowercase.

Consider always setting the transport when setting a port number, since a port number is ambiguous without knowing the transport. For example different processes could be listening on TCP port 12345 and UDP port 12345.

[13] network.type: The value SHOULD be normalized to lowercase.


network.connection.state has the following list of well-known values. If one of them applies, then the respective value MUST be used; otherwise, a custom value MAY be used.

ValueDescriptionStability
close_waitclose_waitRelease Candidate
closedclosedRelease Candidate
closingclosingRelease Candidate
establishedestablishedRelease Candidate
fin_wait_1fin_wait_1Release Candidate
fin_wait_2fin_wait_2Release Candidate
last_acklast_ackRelease Candidate
listenlistenRelease Candidate
syn_receivedsyn_receivedRelease Candidate
syn_sentsyn_sentRelease Candidate
time_waittime_waitRelease Candidate

network.connection.subtype has the following list of well-known values. If one of them applies, then the respective value MUST be used; otherwise, a custom value MAY be used.

ValueDescriptionStability
cdmaCDMADevelopment
cdma2000_1xrttCDMA2000 1XRTTDevelopment
edgeEDGEDevelopment
ehrpdEHRPDDevelopment
evdo_0EVDO Rel. 0Development
evdo_aEVDO Rev. ADevelopment
evdo_bEVDO Rev. BDevelopment
gprsGPRSDevelopment
gsmGSMDevelopment
hsdpaHSDPADevelopment
hspaHSPADevelopment
hspapHSPAPDevelopment
hsupaHSUPADevelopment
idenIDENDevelopment
iwlanIWLANDevelopment
lteLTEDevelopment
lte_caLTE CADevelopment
nr5G NR (New Radio)Development
nrnsa5G NRNSA (New Radio Non-Standalone)Development
td_scdmaTD-SCDMADevelopment
umtsUMTSDevelopment

network.connection.type has the following list of well-known values. If one of them applies, then the respective value MUST be used; otherwise, a custom value MAY be used.

ValueDescriptionStability
cellcellDevelopment
unavailableunavailableDevelopment
unknownunknownDevelopment
wifiWi-FiDevelopment
wiredwiredDevelopment

network.io.direction has the following list of well-known values. If one of them applies, then the respective value MUST be used; otherwise, a custom value MAY be used.

ValueDescriptionStability
receivereceiveRelease Candidate
transmittransmitRelease Candidate

network.transport has the following list of well-known values. If one of them applies, then the respective value MUST be used; otherwise, a custom value MAY be used.

ValueDescriptionStability
pipeNamed or anonymous pipe.Stable
quicQUICStable
tcpTCPStable
udpUDPStable
unixUNIX domain socketStable

network.type has the following list of well-known values. If one of them applies, then the respective value MUST be used; otherwise, a custom value MAY be used.

ValueDescriptionStability
ipv4IPv4Stable
ipv6IPv6Stable

Deprecated Network Attributes

These attributes may be used for any network related operation.

Attributes:

KeyStabilityValue TypeDescriptionExample Values
net.host.ipDeprecated
Replaced by network.local.address.
stringDeprecated, use network.local.address.192.168.0.1
net.host.nameDeprecated
Replaced by server.address.
stringDeprecated, use server.address.example.com
net.host.portDeprecated
Replaced by server.port.
intDeprecated, use server.port.8080
net.peer.ipDeprecated
Replaced by network.peer.address.
stringDeprecated, use network.peer.address.127.0.0.1
net.peer.nameDeprecated
Replaced by server.address on client spans and client.address on server spans.
stringDeprecated, use server.address on client spans and client.address on server spans.example.com
net.peer.portDeprecated
Replaced by server.port on client spans and client.port on server spans.
intDeprecated, use server.port on client spans and client.port on server spans.8080
net.protocol.nameDeprecated
Replaced by network.protocol.name.
stringDeprecated, use network.protocol.name.amqp; http; mqtt
net.protocol.versionDeprecated
Replaced by network.protocol.version.
stringDeprecated, use network.protocol.version.3.1.1
net.sock.familyDeprecated
Split to network.transport and network.type.
stringDeprecated, use network.transport and network.type.inet; inet6; unix (see more)
net.sock.host.addrDeprecated
Replaced by network.local.address.
stringDeprecated, use network.local.address./var/my.sock
net.sock.host.portDeprecated
Replaced by network.local.port.
intDeprecated, use network.local.port.8080
net.sock.peer.addrDeprecated
Replaced by network.peer.address.
stringDeprecated, use network.peer.address.192.168.0.1
net.sock.peer.nameDeprecated
Removed. No replacement at this time.
stringDeprecated, no replacement at this time./var/my.sock
net.sock.peer.portDeprecated
Replaced by network.peer.port.
intDeprecated, use network.peer.port.65531
net.transportDeprecated
Replaced by network.transport.
stringDeprecated, use network.transport.ip_tcp; ip_udp; pipe (see more)

net.sock.family has the following list of well-known values. If one of them applies, then the respective value MUST be used; otherwise, a custom value MAY be used.

ValueDescriptionStability
inetIPv4 addressDevelopment
inet6IPv6 addressDevelopment
unixUNIX domain socket pathDevelopment

net.transport has the following list of well-known values. If one of them applies, then the respective value MUST be used; otherwise, a custom value MAY be used.

ValueDescriptionStability
inprocIn-process communication. [14]Development
ip_tcpip_tcpDevelopment
ip_udpip_udpDevelopment
otherSomething else (non IP-based).Development
pipeNamed or anonymous pipe.Development

[14]: Signals that there is only in-process communication not using a “real” network protocol in cases where network attributes would normally be expected. Usually all other network attributes can be left out in that case.